Few issues a few days on with my Windows 10 upgrade

A few days in and I have solved the few problems I have had

Can apply update Security Update for Windows 10 for x64-based Systems (KB3074683)

My system tried to apply the KB3074683 patch a couple of time, rolling it back each time. A search of the forums found the answer to this one. As in the forum post I have an Nvidia video card, in fact it caused the problems during the update, so the fix was to delete the UpdatusUser registry entry under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList.

Once this was deleted the update applied without an issues.

Windows Defender won’t start

Every time my PC started I got the error that Windows Defender would not start.

image

After much searching and fiddling with settings, it turned out this was a red herring. Defender was not starting as I had another AV product in place System Center End Point Protection, just as the dialog said. End Point Protection is installed by our IT team as part of our standard setup. So the actual issue was that the Defender tooltray app was trying to autostart, giving the error as it failed to connect to the background services which were not running. Strange as this appeared not to be an issue for Windows 8.1.

The answer was to use SysInternal AutoRuns to disable the loading of the tooltray application.

Can access a Data DeDup’d disk

On Windows 8.1 I use the Data DeDup hack on one of my disks that I use for Hyper-V VM; I got 71% disk space saving as there is so much common data between the various VMs. At the time of writing I could not find a matching set of DSIM packages for Windows 10, they need to come from the equivalent release of Server 2016, which is still in CTP/Preview.

After some fiddling with feature packs from preview builds,  I decided to just stop using Data DeDup feature for now. So I attached my disk to a 8.1 machine with DeDup enabled, copied the contents off, re-formated the disk and the replaced the data. then put the disk back in my laptop.

I do hope Microsoft choose to add Data DeDup to Windows 10 in the future, it is of great use to me and anyone else who uses plenty of local VMs.

 

 

So I think I am there now, let us see how reliable it is day to day.

Upgrade from Windows 8.1 to Windows 10 on my Lenovo W520

I have just done an in place upgrade on my Lenovo W520 from Windows 8.1 to Windows 10. Something I had not tried during the beta programme, sticking to running Windows 10 in VMs (mostly on Azure).

I have to say the process was pretty smooth. I only hit one issue, and this was the usual NVidia Optimus problems I saw installing Windows 8 and 8.1.

This is what happened

  1. With Windows 8.1 running mounted the Windows 10 Enterprise ISO
  2. Ran the setup
  3. It did a few checks and eventually asked if I wanted to keep everything – I said yes
  4. It showed a percentage complete gauge
    1. It copied files OK (about 30%)
    2. It said it had found 5% of drivers (32% overall) and stopped – I left it a couple of hours, no disk or network activity

At this point I was a bit worried. But guessed it was the same problem as I had seen on Windows 8.x; the installer needs to access the Intel GPU as well as the NVidia GPU else it gets confused and hangs. A disabled GPU is not an removed GPU.

So I

  1. I rebooted (via the power switch)
  2. Boot into BIOS (press the ThinkVantage button)
    1. Selected the Enable Nvidia Optimus in the graphics options
    2. Saved and rebooted
  3. The PC rolled back the Windows 10 update (very quickly, less than 5 minutes)
    Note: I had expected to be challenged for a Bitlocker code due to the BIOS setting change during the reboot but I wasn’t
  4. With Windows 8.1 running again I re-mounted the Windows 10 Enterprise ISO
  5. Ran the setup again
  6. It did the same few checks and eventually asked if I wanted to keep everything – I said yes again
  7. This time it completed without error, it took around an hour

So now I had an upgraded PC, and everything seemed OK. Including my Biometric login – I was surprised me as this had been a problem to setup in the past.

Only issue was with my external screen, so went back into the BIOS to disable NVidia Optimus again. This time it did prompt me to re-enter the Bitlocker key. Once this was done I could use external screens with no issues as before.

So a smooth upgrade from our standard Windows 8.1 dev machine image, a good stop gap until our IT team build a Windows 10 image in Systems Center.