But it works on my PC!

The random thoughts of Richard Fennell on technology and software development

Solution to ‘Missing requirement: Shared profile 1.0.0.1308118925849’ error when installation TEE SP1 on Eclipse Indigo

[Updated 1 mar 2012 - This should only effect you if Eclipse is unzipped into your 'c:\program files' folder structure)

During my new laptop build I have had to reinstall Eclipse, so I took the chance to upgrade to the Indigo release. When I tried to install the TFS 2010 Team Explorer Everywhere SP1 plug-in I got the error

Cannot complete the install because one or more required items could not be found.
  Software currently installed: Shared profile 1.0.0.1308118925849 (SharedProfile_epp.package.java 1.0.0.1308118925849)
  Missing requirement: Shared profile 1.0.0.1308118925849 (SharedProfile_epp.package.java 1.0.0.1308118925849) requires 'org.maven.ide.eclipse [1.0.0.20110607-2117]' but it could not be found

This stumped me for a while, but after a bit of searching on Eclipse forums I found this was a problem common to installing other plug-ins, not just TEE, so not a TEE dependency as the error suggests.

The issue was you have to be running Eclipse as an administrator to install the plug-in. Judging from the forums this has tripped a few people up with plug-ins on the Indigo release, seems this was not the case with the previous releases such as Helios.

Once you have installed the plug-in as administrator you can restart Eclipse in standard mode and connect to your TFS server as you would expect.

Comments (6) -

  • Richard

    8/2/2011 2:52:00 AM |

    Awesome!  Thanks for the tip.  Worked just fine after I started Eclipse as administrator.

  • Richard

    9/18/2011 5:45:53 AM |

    Great, I just stumbled across this page from a google search and it saved me! Man i was having hard time trying to figure this thing out i was almost going to give up.
    Thank you very much Smile

  • Richard

    9/24/2011 9:06:56 PM |

    Thanks for the tip, very helpful.

  • Richard

    9/28/2011 4:57:23 PM |

    Just a comment, I'm having this issue with a Helios release (SR2), so I'm not sure this only happens with Indigo.

  • boaz

    2/5/2012 3:12:10 PM |

    I have the same problem, running on linux, no admin account Smile
    any ideas ?
    I tried running eclipse using root , same problem.
    btw, I try to install statET when getting the error :

    Cannot complete the install because one or more required items could not be found.
      Software currently installed: Shared profile 1.0.0.1313312081469 (SharedProfile_epp.package.java 1.0.0.1313312081469)
      Missing requirement: Shared profile 1.0.0.1313312081469 (SharedProfile_epp.package.java 1.0.0.1313312081469) requires 'org.maven.ide.eclipse [1.0.0.20110607-2117]' but it could not be found

  • richard

    2/5/2012 7:12:18 PM |

    Using sudo would be my initial suggestion, but I guess you have tried that. I have not heard of this issue on OS other than Windows

Pingbacks and trackbacks (2)+

Comments are closed