But it works on my PC!

The random thoughts of Richard Fennell on technology and software development

Outlook 2010 email searching

Since I installed Outlook 2010 technical preview I have not been able to search emails using the ‘search mail’ boxes in Outlook (which links into Windows desktop search). I had not realised how much I used the feature until it did not work. When I tried a search I was shown a dialog saying there was 40000+ items waiting to be indexed, and this number was not changing. It seemed that the indexing of Outlook contents had stopped.

The solution I found was to reset the indexing process.

  1. In Outlook select the back stage (brown button)
  2. Select Outlook options
  3. Select Search
  4. Select Indexing Options button
  5. Use the modify button to remove all options from the locations to be indexed
  6. Use the advanced button to select a re-index (with nothing selected)
  7. Use modify button again to re-select all the item you want to index (including Outlook)
  8. Finally use the advanced button again to select the re-index option to restart the process
  9. I then had to wait 24 hours, but at least I could see the index items count going up at the top of the Indexing options dialog until I got the message Indexing complete..

Visual Studio 2008 connecting to TFS 2010

You can connect a Visual Studio 2008 IDE instance to a TFS 2010 server, as detailed in Martin Hinshelwood’s blog, but I cannot stress enough you have to have VS2008 SP1 installed. If you don’t, you get an error dialog when you enter the URL for the TFS server saying the URL contains invalid characters.

This seems a simple rule, but as I found today it is easy to not realise your PC is not patched. You look in the about dialog for Visual Studio and it says SP1 installed, but the Team Foundation Client has not been. This was because the following installation order was followed:

  1. Install VS2008
  2. Patch with SP1
  3. Install Team Foundation Client

The SP1 needed to be run again to patch the client then all was OK

A major day in history

With all this coverage of the moon landings I am surprised that the other major news item of 40 years ago today has not been covered – the Fennell family moved house. I ask you just what are the priorities of the news media?

Outlook 2010 crashing after in place upgrade

I downloaded and installed the Office 2010 technical preview today. All seemed to go OK (after I realised  I could only do an in place upgrade from 32bit Office 2007 –> 32bit Office 2010), once the upgrade was done I could load Word and using our VSTO based document templates all seemed to work fine. However when I tried Outlook I got a problem.

On the first loading it took a while, telling me it was doing something to  40K+ items, presumably checking the local OST file, but then seemed to load OK. However after about 30 seconds it crashed, and continued to do this every time I rebooted Outlook even when I was tried safe mode, add-ins switched off and/or offline working. It all had no effect. Checking the event log I saw I had the error:

Faulting application name: OUTLOOK.EXE, version: 14.0.4006.1110, time stamp: 0x4a468538
Faulting module name: mlang.dll, version: 6.1.7100.0, time stamp: 0x49eea59f
Exception code: 0xc0000005
Fault offset: 0x00016aef
Faulting process id: 0x1060
Faulting application start time: 0x01ca06e3140fb30d
Faulting application path: C:\Program Files (x86)\Microsoft Office\Office14\OUTLOOK.EXE
Faulting module path: C:\Windows\system32\mlang.dll
Report Id: 5af5a171-72d6-11de-97df-001636a51764

I noticed that the in place upgrade had not removed Office 2007, so I did this via the control panel. After this Outlook loaded and was stable other than the fact the view panel would not load (was grey’d out on the menu), so stable but useless

I then tried a removing Office 2010 (there is no repair option) and reinstalling again using the same 32bit media. This time it knew it was not doing an upgrade but a new install. Once this completed I loaded Outlook and it worked fine including picking up my existing OST file (from a non default location, I keep it on a bitlocker partition) and also still had my CRM 4.0 add-in configured and working.

So it seems the upgrade can get  bit confused

My Glasgow presentation last night.

Thanks to everyone who turned up for my presentation on Typemock and Sharepoint in Glasgow last night. I have just upload my slides onto the Black Marble site. As the session was quite demo driven the slides don’t offer the best code samples. If you want to experiment yourselves I would suggest you look at my related posts on this blog and remember if you don’t have Typemock you can download trial versions of all the products I used from www.typemock.com

Video recording gotta for VS2010 Test Runner

VS2010 has excellent new features to assist the tester in general, and specifically in the area of manual testing. One of these is the ability to video a manual test run; to get this to work you have to have the Windows Media Encoder 9 installed as well as the VS2010 Test Runner . If you don’t have it installed and try to use the video feature you get a dialog that warns you this component is missing and would you like to either download it or disable video recording feature for this test run.

The problem is the warning dialog has a link that takes to you the Windows Media Encoder 9 homepage. This gives you the option to install either the 32bit or 64bit version. I mistakenly assumed that I needed the version for operating system I have i.e. 64bit as I run 64bit Windows 7. THIS IS WRONG.

VS2010 Test Runner only seems to work if you have to install the 32bit and the hotfix the Test Runner dialog mentions. Once I installed the 32bit video recording of the test worked perfectly.

And eScrum is no more

I have posted in the past about the TFS 2005 and 2008 Process Template eScrum from Microsoft; a template we use internally for a number of Agile projects. Well today it has been removed from the Microsoft download sites.

It was decided a while ago that it would not be updated to support TFS2010 and has been removed to avoid any confusion over whether it is support or not by Microsoft (FYI it was never officially supported anyway as it did not originate inside the TFS team)

So are we at Black Marble going to miss it? Well the main reason we had used it in the past was the web interface that gave a single point for updating the status of work items without the need to enter Visual Studio, it was our project wallboard. With the much enhanced Office integration with TFS2010 I think we are not going to miss eScrum. We can now provide an easy way with Excel or Project for any team member (developer or not) to update their work status and also Excel Services to provide a information radiator showing the overall project status.

If you do need a strict Scrum implementation template for TFS then have a look at Conchango’s Scrum for Team System which is going to be updated to make use of all the new features of TFS2010

Fun with a SQLExpress 2005 upgrade 2008

On my development PC I had a 2005 instance of SQLExpress that was installed as part of the VS2008 setup. I thought I had upgraded it when I put on the SQL 2008 Management tools and/or VS2010 beta, but it seems I didn’t. I thought I would try the new Microsoft Web Platform Installer, but this also thought I had done the upgrade to 2008, I suspect due to the fact I had the 2008 management tools.

Note: If you are using the Microsoft Web Platform Installer 2.0 RC remember you can’t just click on it to run from the web if you are running as a non-administrator user on your PC (as you should be, running least privilege). You need to download it and ‘run it is administrator’ or open it in a browser running as administrator to get it t even load.

So I needed to download the SQLExpress 2008 media to do a manual upgrade, as I remembered I could not use the developer edition media I had to hand to upgrade and Express instance. This download in itself proved problematic. I did a downloaded from MSDN, but the file I got gave a ‘not a valid win32’ error when I tried to run it. Also I noticed each time I tried to download it in IE8 it was a different size – not a good sign! Once I swapped to Firefox it downloaded without issue.

Anyway in the end I got the right media and access rights and the upgraded went smoothly. However then I tried to attach a 2008 DB (the reason I needed the upgrade in the first place) I got the error

Parameter name: nColIndex
Actual value was -1. (Microsoft.SqlServer.GridControl)

image

I had yet again forgotten to run SQL Management Studio as an administrative user. This error dialog is SQL Management Studio was of saying you don’t have the rights!